Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: very important request - if image not exist

  1. #11
    Join Date
    May 2005
    Location
    China & France
    Posts
    6,492

    Default

    Quote Originally Posted by cuveyx View Post
    i have a custom theme. could you please tell me where can i find the code to look ?

    if i delete an image i get nothing...
    Please check the function "function processOutput($image,$output_type)" in includes/core.func.php.

  2. #12

    Default

    i have it but not working ?

    Code:
    * process output
    */
    function processOutput($image,$output_type)
    {
    global $db,$input,$user,$baseWeb,$ImageFile,$ThumbFile,$VideoFile;
        /**
    ps: i use direct links...
    Last edited by cuveyx; 06-06-2010 at 09:12 AM.

  3. #13
    Join Date
    May 2005
    Location
    China & France
    Posts
    6,492

    Default

    Please edit these lines in function "processOutput",
    PHP Code:
    $suspended_file='skin/'.$user->setting[skin_dir].'/sys_icons/AccountSuspend.jpg';
        
    $deleted_file='skin/'.$user->setting[skin_dir].'/sys_icons/ImageNotFound.jpg';
        
    $overbandwidth_file='skin/'.$user->setting[skin_dir].'/sys_icons/BandwidthOut.jpg';
        
    $smallthumb_file='skin/'.$user->setting[skin_dir].'/sys_icons/SmallThumb.jpg';
        
    $hotlinked_file='skin/'.$user->setting[skin_dir].'/sys_icons/NoHotlink.jpg'

  4. #14

    Default

    in root/include/core.func.php did this

    Code:
    * process output
    */
    function processOutput($suspended_file='skin/'.$user->setting[skin_dir].'/sys_icons/AccountSuspend.jpg';
        $deleted_file='skin/'.$user->setting[skin_dir].'/sys_icons/ImageNotFound.jpg';
        $overbandwidth_file='skin/'.$user->setting[skin_dir].'/sys_icons/BandwidthOut.jpg';
        $smallthumb_file='skin/'.$user->setting[skin_dir].'/sys_icons/SmallThumb.jpg';
        $hotlinked_file='skin/'.$user->setting[skin_dir].'/sys_icons/NoHotlink.jpg';)
    {
    global $db,$input,$user,$baseWeb,$ImageFile,$ThumbFile,$VideoFile;
        /**
    i still not working.

    and homepage says:

    Code:
    Parse error:  syntax error, unexpected '.', expecting ')' in /home/user/public_html/includes/core.func.php  on line 1080
    1080 is this

    function processOutput($suspended_file='skin/'.$user->setting[skin_dir].'/sys_icons/AccountSuspend.jpg';
    what am i doing wrong ?

    neither this works

    * process output
    */
    function processOutput($image,$output_type
    $suspended_file='skin/'.$user->setting[skin_dir].'/sys_icons/AccountSuspend.jpg';
    $deleted_file='skin/'.$user->setting[skin_dir].'/sys_icons/ImageNotFound.jpg';
    $overbandwidth_file='skin/'.$user->setting[skin_dir].'/sys_icons/BandwidthOut.jpg';
    $smallthumb_file='skin/'.$user->setting[skin_dir].'/sys_icons/SmallThumb.jpg';
    $hotlinked_file='skin/'.$user->setting[skin_dir].'/sys_icons/NoHotlink.jpg';
    )
    {
    global $db,$input,$user,$baseWeb,$ImageFile,$ThumbFile,$V ideoFile;
    /**
    * process output
    */
    function processOutput($image,$suspended_file='skin/'.$user->setting[skin_dir].'/sys_icons/AccountSuspend.jpg';
    $deleted_file='skin/'.$user->setting[skin_dir].'/sys_icons/ImageNotFound.jpg';
    $overbandwidth_file='skin/'.$user->setting[skin_dir].'/sys_icons/BandwidthOut.jpg';
    $smallthumb_file='skin/'.$user->setting[skin_dir].'/sys_icons/SmallThumb.jpg';
    $hotlinked_file='skin/'.$user->setting[skin_dir].'/sys_icons/NoHotlink.jpg';
    )
    {
    global $db,$input,$user,$baseWeb,$ImageFile,$ThumbFile,$V ideoFile;
    /**
    Last edited by cuveyx; 06-06-2010 at 09:49 PM.

  5. #15

    Default

    bump. yabsoft, could you please tell me what to do ?

  6. #16

    Default

    here is htaccess and core.func.php.

    could you help me please ? i need this

    http://www.mediafire.com/?guyojzmdykd

  7. #17
    Join Date
    May 2005
    Location
    China & France
    Posts
    6,492

    Default

    Quote Originally Posted by cuveyx View Post
    here is htaccess and core.func.php.

    could you help me please ? i need this

    http://www.mediafire.com/?guyojzmdykd
    Please find those lines in core.func.php and change the filename to yours. for example,
    PHP Code:
    $suspended_file='skin/'.$user->setting[skin_dir].'/sys_icons/AccountSuspend.jpg'
    to
    PHP Code:
    $suspended_file='skin/'.$user->setting[skin_dir].'/sys_icons/YourAccountSuspend.jpg'
    Please make sure you have the images in the folder skin/<skin_name>/sys_icons.

  8. #18

    Default

    i duplicated the ImageNotFound.jpg renamed to YourImageNotFound.jpg

    and uploaded to /skin/default/sys_icons/YourImageNotFound.jpg

    then went to root/included/core.func.php and edited line 1084

    Code:
    /**
    * process output
    */
    function processOutput($image,$output_type)
    {
    global $db,$input,$user,$baseWeb,$ImageFile,$ThumbFile,$VideoFile;
        /**
        * prepare var
        */
        $id=$image[id];
        $suspended_file='skin/'.$user->setting[skin_dir].'/sys_icons/AccountSuspend.jpg';
        $deleted_file='skin/'.$user->setting[skin_dir].'/sys_icons/YourImageNotFound.jpg';
        $overbandwidth_file='skin/'.$user->setting[skin_dir].'/sys_icons/BandwidthOut.jpg';
        $smallthumb_file='skin/'.$user->setting[skin_dir].'/sys_icons/SmallThumb.jpg';
        $hotlinked_file='skin/'.$user->setting[skin_dir].'/sys_icons/NoHotlink.jpg';
        $filetype=substr(strtolower(strrchr($image[file],'.')),1);
        $images_table=$image[gallery_id]?'images4g':'images';
    
        /**
    no results

    if i have direct links and multiserver... ImageNotFound.jpg will not work?
    Last edited by cuveyx; 06-09-2010 at 09:24 PM.

  9. #19

    Default

    i have solved this by htaccess
    Code:
    <FilesMatch "(php4|php|pl|cgi|ini)$">
    order deny,allow
    deny from all
    </FilesMatch>
    errordocument 404 /thumb/theimg.gif
    if image not found - theimg.gif will load

  10. #20

    Default

    works ! THANK YOU.

Similar Threads

  1. CPU Exceeded Log, please look yap
    By kuaza in forum Troubleshooting And Problems
    Replies: 2
    Last Post: 04-26-2009, 01:40 AM
  2. Solution for "Error:Stamp image is not set"
    By yabsoft in forum Document & Tutorials!
    Replies: 0
    Last Post: 07-27-2008, 02:02 PM
  3. Urgent! site is not working correct after migration
    By innovatorr in forum MFHS v1.1
    Replies: 9
    Last Post: 11-21-2006, 03:42 PM
  4. Replies: 1
    Last Post: 01-01-2006, 10:22 AM
  5. Uploading Group image or Multi image
    By Walim in forum Suggestions & Feature Request
    Replies: 2
    Last Post: 10-29-2005, 02:28 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •