Results 1 to 2 of 2

Thread: ! urgent

  1. #1

    Unhappy ! urgent

    hello , i have problems with file upload and cgi-bin directory

    1. when i uploading something it shows "Initializing upload ..." and nothing happens , i uploaded cgi-bin content in ANSII chmoded 755. if i enabling debug
    i see perl script in iframe ...like opened with notepad

    2. i ran server test from admin panel its show 404 (cgi-bin) i placed index.html
    in cgi-bin dir then i open www.......com/cgi-bin/index.html ERROR 404 !!!

    so i renamed cgi-bin to cgi , changed path to "cgi" in Admin panel , perfect now no errors , but apeared new error ! :

    --------------------------------------------------
    #!/usr/bin/perl ## ## printenv -- demo CGI program which just prints its environment ## use CGI; use Fcntl qw(EFAULT :flock); use File::Temp qw/ tempfile tempdir /; use CGI::Carp qw/fatalsToBrowser/; print "Content-type: text/html; charset=iso-8859-1\n\n"; print qq _
    CGI-BIN Requirement Detecting
    _; for('LWP', 'CGI','Fcntl','File::Temp') { eval "require $_"; if($@) { print "\nThe $_ module is required, but could not be found!
    "; } else { print "\nThe $_ module".($_ eq 'CGI'?'(v'.$CGI::VERSION.')':'')." is installed!
    "; } } print qq _
    ----------------------------------------------------


    please help me , please tell why i cant use cgi-bin dir , and in overall is this server problems what module i'm missing

  2. #2
    Join Date
    May 2005
    Location
    China & France
    Posts
    6,492

    Default

    It seems cgi-bin is not active to execute the perl script. Please ask your hosting to enable cgi-bin on your site.

Similar Threads

  1. Replies: 4
    Last Post: 09-01-2007, 04:07 PM
  2. We need fix for the accesskey problems! Urgent!
    By NextBest in forum MFHS v1.2
    Replies: 4
    Last Post: 01-09-2007, 02:46 PM
  3. big issue, urgent.. too many users at same time
    By innovatorr in forum MFHS v1.1
    Replies: 0
    Last Post: 01-08-2007, 08:29 PM
  4. Urgent! site is not working correct after migration
    By innovatorr in forum MFHS v1.1
    Replies: 9
    Last Post: 11-21-2006, 03:42 PM
  5. Hotlinking problem; URGENT!
    By umairmasoodpk@gmail.com in forum Troubleshooting And Problems
    Replies: 4
    Last Post: 10-23-2006, 05:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •